Διαδικασίες

Διαδικασία στη Logo είναι ένα σύνολο εντολών που ομαδοποιούνται σε ένα νέο όνομα. Κάθε διαδικασία έχει ένα όνομα μέσω του οποίου μπορούμε να ζητήσουμε την εκτέλση του συνόλου των εντολών της διαδικασίας. Το όνομά της διαδικασίας μπορεί να χρησιμοποιηθεί είτε στο κέντρο εντολών είτε μέσα σε άλλη διαδικασία. Γράφουμε τις διαδικασίες στη MicroworldsPro, στην καρτέλα διαδικασίες.

Σύνταξη:

για όνομα-διαδικασίας

εντολή1

εντολή2

.

.

.

τέλος

Κάθε διαδικασία πρέπει να ξεκινάει με την λέξη για και να τελειώνει με την λέξη τέλος. Το όνομα-διαιδκασίας δεν πρέπει να είναι κάποια δεσμευμένη λέξη της Logo π.χ. δείξε.




Παράδειγμα1:

Στην καρτέλα διαδικασίες πληκτρολογούμε την διαδικασία με όνομα τετράγωνο:

για τετράγωνο

στκ

επανάλαβε 4 [μπ 100 δε 90]

τέλος

Στη συνέχεια γράφοντας απλά το όνομα της διαδικασίας τετράγωνο στο κέντρο εντολών σχηματίζεται:

logo-square.JPG









Παράδειγμα2:

Στην καρτέλα διαδικασίες πληκτρολογούμε την διαδικασία με όνομα πέταλο:


για πέταλο

στκ

επανάλαβε 90 [μπ 1 δε 1] δε 90

επανάλαβε 90 [μπ 1 δε 1] δε 90

τέλος

Στη συνέχεια γράφοντας απλά το όνομα της διαδικασίας πέταλο στο κέντρο εντολών σχηματίζεται:

petalo.png

Για να σχηματίσει η χελώνα ένα λουλούδι που θα αποτελείται απο 6 πέταλα θα πρέπει να καλέσουμε την

διαδικασία πέταλο 6 φορές. Αφού σχηματίσει η χελώνα το κάθε πέταλο θα πρέπει να στρίβει κατά 360/6 μοίρες,

έτσι ώστε στο τέλος του σχηματισμού των 6 πετάλων να έχει κάνει μία πλήρη περιστροφή (360 μοιρών) και να

έχει επιστρέψει στην αρχική της θέση.

Οπότε η διαδικασία που σχηματίζει λουλούδι με 6 πέταλα είναι η εξής:

για λουλούδι

στκ

επανάλαβε 6 [πέταλο δε 360 / 6 ]

τέλος


flower6.png





question.jpgΠαρατήρηση:

Καλή προγραμματιστική αρχή στην Logo είναι να φροντίζουμε έτσι ώστε στο τέλος της διαδικασίας μας να υπάρχουν οι κατάλληλες εντολές που θα επιστρέφουν την χελώνα στην άρχική της θέση.

Έτσι θα μπορείτε να συνθέτετε τις διαδικασίες σας χωρίς να αναρωτιέστε κάθε φορά που βρίσκεται η χελώνα.





computer-practise.jpg

Δραστηριότητες:




Φύλλο Εργασίας 1: Ας παίξουμε με τα τετράγωνα

cross.jpg pdf.jpg doc.jpg



Φύλλο Εργασίας 2: Τετράγωνα και τρίγωνα

village1.JPG pdf.jpg doc.jpg

Φύλλο Εργασίας 3: Τετράγωνα, παραλληλόγραμμα και κύκλοι

train2.jpg pdf.jpg doc.jpg

Φύλλο Εργασίας 4: Πέταλα, κύκλοι, τρίγωνα

2.png pdf.jpg doc.jpg

Φύλλο Εργασίας 5: Υπολογισμός εμβαδού, ΦΠΑ, έκπτωσης

emvado.png pdf.jpg doc.jpg