Παράμετροι σε διαδικάσιες

Οι διαδικασίες που εσείς ορίζετε μπορούν επίσης να έχουν εισόδους.
Η διαδικασία τετράγωνο μπορεί να τροποποποιηθεί, έτσι ώστε, αντί να σχεδιάζει ένα τετράγωνο
με πλευρά μήκους 100 βημάτων κάθε φορά, να σχεδιάζει τετράγωνα με διαφορετικά μεγέθη.

για τετράγωνο :πλευρά
επανάλαβε 4 [μπροστά :πλευρά δεξιά 90]
τέλος

Τώρα, κάθε φορά που θέλετε να εκτελέσετε τη διαδικασία τετράγωνο, πρέπει να προσδιορίσετε
το μήκος της πλευράς του τετραγώνου που θέλετε να σχεδιαστεί. Μπορείτε να την εκτελέσετε όπως
κάθε εντολή Logo με εισόδους. Για παράδειγμα, για να σχεδιάσετε ένα τετράγωνο με πλευρές
μήκους 50 βημάτων, πληκτρολογήστε το εξής:
τετράγωνο 50

Για να σχεδιάσετε ένα μικρό τετράγωνο, πληκτρολογήστε:
τετράγωνο 10

Έχετε τη δυνατότητα να ορίσετε διαδικασίες Logo με περισσότερες από μία εισόδους.
Ένα παράδειγμα διαδικασίας που απαιτεί δύο εισόδους είναι το ορθογώνιο:

για ορθογώνιο :μήκος :πλάτος
επανάλαβε 2 [μπ :πλάτος δε 90 μπ :μήκος δεξιά 90]
τέλος

Για να σχεδιάσετε ένα ορθογώνιο με πλευρές 100 και 50, πληκτρολογήστε:
ορθογώνιο 100 50



computer-practise.jpg

Δραστηριότητες:


Δραστηριότητα1: Γράψτε διαδικασία με όνομα πολύγωνο που θα παίρνει ως παραμέτρους 2 αριθμούς

  • τον αρθμό των πλευρών του πολυγώνου

  • το μήκος της πλευράς

και θα σχηματίζει κανονικό πολύγωνο.

Έτσι η κλήση της διαδικασίας

πολύγωνο 3 100, θα σχηματίζει τρίγωνο με μήκος πλευράς 100

πολύγωνο 4 70, θα σχηματίζει τετράγωνο με μήκος πλευράς 70

πολύγωνο 6 50, θα σχηματίζει εξάγωνο με μήκος πλευράς 50


Φύλλο Εργασίας 4: Πέταλα, κύκλοι, τρίγωνα

2.pngpdf.jpgdoc.jpg